Back to overview
Degraded

Microsoft partial outage affecting all Voice365 customers

Sep 06 at 10:19am CEST
Affected services
Voice365 Services
Voice365 User/Bridge Service

Resolved
Sep 06 at 11:26am CEST

Resolved:
Microsoft will update the incident on their side via the Service Health portal.
We see a positive improvement since 10:45CEST.

Updated
Sep 06 at 11:00am CEST

Update: Microsoft has identified the issue. The incident can be followed on the Service Health dashboard of Microsoft with IncidentID TM673780.

"Title: Users may be unable to make or receive Public Switched Telephone Network (PSTN) calls in Microsoft Teams

User impact: Users may be unable to make or receive PSTN calls in Microsoft Teams.

Current status: We're reviewing service monitoring telemetry to isolate the source of the issue and establish a fix.

Scope of impact: Impact is specific to some users who are served through the Europe, Middle East, and Africa region."

Updated
Sep 06 at 10:53am CEST

Update: We see that affected calls are decreasing starting from 10:45CEST

Created
Sep 06 at 10:19am CEST

Since this morning (09:30CEST) we received several notification of Microsoft rejecting calls with an error "Service unavailable".

Due to this Microsoft 365 issue Voice365 customer might have a degraded performance on their Teams service affecting inbound and outbound calls.

We strongly advice our customers and partners to raise a ticket with Microsoft in order to make Microsoft aware of this Direct Routing issue more quickly and collectively put the appropriate urgency on this issue.

Our partners are able to set call forwards on your numbers to prevent the unreachability of your organisation.