Back to overview

Issue KPN WBA

Jun 23 at 01:54am CEST
Affected services
Customer DSL Network

Resolved
Jun 23 at 01:54am CEST

We are currently investigating an issue regarding KPN WBA.
We will come back later with more details.
The issue was caused by maintenance at KPN